SQL Job stating that a connection was not valid on an XSL file

I'm receiving an error on a package I created which uses XSL file. I noticed I receive the following error:

Description: The file name "C:\Users\\Documents\Visual Studio 2008\Projects\Packages\Product Transfers Daily\Product Transfers Daily\ProductTransfers-Whses.XSL" 
specified in the connection was not valid. 
I can run the package fine in BIDS without any issue which leads me to a permissions issue but permissions have not changed and all other packages are working fine.

Is there something I am overlooking? This job worked fine for the last year or more. If I have not given enough information please let me know and I will provide.

more ▼

asked Oct 18, 2012 at 06:35 PM in Default

avatar image

1.2k 62 66 68

So the file and path is local on the SQL server the package is running from?

Oct 18, 2012 at 06:41 PM Shawn_Melton

Yes it is local on the SQL Server. I have deployed the package to SQL Server so it shows in MSDB and fails when running in there. The job Step properties looks at the SQL Server for the Package Source, the server name is entered, and the package: is set to the Package Name. Hope this answeres your question.

Oct 18, 2012 at 07:32 PM Noonies

Have you verified that the service account SQL Server Agent is configured to has rights to the location of that file?

Oct 18, 2012 at 08:45 PM Shawn_Melton

Yes! I have the account in the server administrators group. Should I try to add it separately for permissions?

Oct 18, 2012 at 08:52 PM Noonies

I would suggest moving the file out of the profile (Users) directory. I would place it on a central folder on the server, then ensure the account has specific rights to the folder/directory.

Oct 18, 2012 at 08:54 PM Shawn_Melton
show all comments (comments are locked)
10|1200 characters needed characters left

2 answers: sort voted first

Hi Shawn! Thanks again for all your help! I noticed that this did tie to permissions. I had a broken SID due to an account being migrated to a new domain. Though the account was part of the Administrators group, this was not allowing appropriate permissions for whatever reason. I have readded the account to have access to the files. I will take your suggestion when I move the SQL server from physical to VM this weekend. Thank you again - your time is greatly appreciated!

more ▼

answered Oct 31, 2012 at 03:51 PM

avatar image

1.2k 62 66 68

(comments are locked)
10|1200 characters needed characters left

Hi... Try running it by selecting '32-bit Runtime' in the job step.

more ▼

answered Oct 31, 2012 at 11:02 AM

avatar image

550 10 25 18

I had tried that. I need to mark my last comment to Shawn as the issue and post as an answer. Thank you for taking a look at this DharmanDave.

Oct 31, 2012 at 03:51 PM Noonies
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.



asked: Oct 18, 2012 at 06:35 PM

Seen: 922 times

Last Updated: Oct 31, 2012 at 03:51 PM

Copyright 2016 Redgate Software. Privacy Policy