Ssis package fails when run as job.

I created this ssis package on my pc. It runs great. But not when scheduled as a job.

I've searched all over the internet none of the fixes work.

Tried changing to savesentivewith password

tried changing runtime64bit to false

tried changing owner

NOTHING works. I am so frustrated

I have alot of servers this is the only one causing problems.

Date 9/28/2012 4:38:05 PM Log Job History (test)

Step ID 1 Server EQUINOX Job Name test Step Name test Duration 00:00:01 Sql Severity 0 Sql Message ID 0 Operator Emailed
Operator Net sent
Operator Paged
Retries Attempted 0

Message Executed as user: EQUINOX\SYSTEM. ...ion 9.00.5000.00 for 64-bit Copyright (C) Microsoft Corp 1984-2005. All rights reserved. Started: 4:38:05 PM Error: 2012-09-28 16:38:05.82 Code: 0xC0202009 Source: partspostbyreversals Connection manager "Excel Connection Manager 2" Description: SSIS Error Code DTS_E_OLEDBERROR. An OLE DB error has occurred. Error code: 0x80040154. An OLE DB record is available. Source: "Microsoft OLE DB Service Components" Hresult: 0x80040154 Description: "Class not registered". End Error Error: 2012-09-28 16:38:05.82 Code: 0xC020801C Source: Insert to Processed Excel Destination [7962] Description: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER. The AcquireConnection method call to the connection manager "Excel Connection Manager 2" failed with error code 0xC0202009. There may be error messages posted before this with more information on why the AcquireConnection method call fai... The package execution fa... The step failed.

more ▼

asked Sep 28, 2012 at 09:03 PM in Default

avatar image

866 49 64 68

I'm not sure, but maybe a component is missing on that machine which now has to execute the package. Also, there's a difference when running a package from your computer (32 bit BIDS) and running from a server (64 bit!) Maybe there's the issue.

Sep 29, 2012 at 01:06 PM DirkHondong
(comments are locked)
10|1200 characters needed characters left

3 answers: sort voted first

Maybe this information helps : http://beyondrelational.com/modules/2/blogs/66/posts/9933/ssis-consuming-microsoft-access-or-microsoft-excel-data-sources-in-64-bit-environments.aspx

I suppose it has something to do with the different environments (32bit client against 64bit server)

more ▼

answered Sep 29, 2012 at 01:09 PM

avatar image

1.3k 15 19 24

(comments are locked)
10|1200 characters needed characters left

FYI Had to create a new Credential to use for the ssis and then it worked.

more ▼

answered Dec 19, 2012 at 04:17 PM

avatar image

866 49 64 68

Interesting to know. Thank you for stopping by :)

Dec 21, 2012 at 10:28 AM DirkHondong
(comments are locked)
10|1200 characters needed characters left

I got the same issue before 1 year ago at that I was follow the above steps (Hondong metioned)

more ▼

answered Dec 26, 2012 at 04:42 PM

avatar image

276 9 11 14

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.



asked: Sep 28, 2012 at 09:03 PM

Seen: 3604 times

Last Updated: Dec 27, 2012 at 09:41 AM

Copyright 2018 Redgate Software. Privacy Policy