adding new sql server registration - login fail


I tried to create connection to remote sql server through Enterprise Manager. I have Microsoft SQL Server 2000. I configure sql Connection Alias in Client Network Utility. Then I go to Enterprise Manager and add New SQL Server Registration under SQL Server Group. I follow the wizard until complete then I got error message something like registration not success. logon for user natasha failed. For sure it's not firewall problem because I can use remote desktop to go to that server.

Thanks in advance

more ▼

asked May 04, 2012 at 04:41 PM in Default

avatar image

0 1 1 1

(comments are locked)
10|1200 characters needed characters left

1 answer: sort voted first

Can you ping the server and the port from the machine you're trying to connect to? If you can't do both, that's the beginning of the issue.

more ▼

answered May 04, 2012 at 05:14 PM

avatar image

Grant Fritchey ♦♦
137k 20 47 81

I can access the server by using remote desktop (in remote desktop, I input ip and port). Is't that same thing with ping.

May 04, 2012 at 05:29 PM knowledge_base

The port for remote desktop is different than the port for SQL Server. Make sure you're testing the right port. If that port isn't accessible, then you'll need to poke a hole in the firewall to let that communication through.

May 04, 2012 at 06:11 PM Grant Fritchey ♦♦


I think the problem is in configuration. My co-worker can access the same sql database thru sql Management Studio. She has SQL server 2008. I have 2000. I don't have management studio and I don't want to un-install/re-install. I have close to 0 knowledge in sql server so I must have missed something. My co-worker doesn't know much too. This's the first time we tried to go in sql server.

May 04, 2012 at 08:15 PM knowledge_base

I saw in the post that someone has the same problem and the problem got resolve by going to security tab in property and then chose the authentication mode that allows both Windows and SQL Server authentication. I want to tried that but I cannot get to the property. When I right click on my sql server then select property, I got error msg as below.

A connection counld not be estrablished to srvabc\dbxyz. Reason: Logon failed for user 'myusrid'

May 04, 2012 at 09:05 PM knowledge_base

If you're trying to connect to a 2008 or 2008R2 server, you may need to have that level of management studio.

That last error makes it sound like your login doesn't have correct permissions or isn't actually registered on the server.

May 05, 2012 at 11:09 AM Grant Fritchey ♦♦
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.



asked: May 04, 2012 at 04:41 PM

Seen: 1059 times

Last Updated: May 05, 2012 at 06:20 PM

Copyright 2018 Redgate Software. Privacy Policy