x

Report is not showing in the application

I have a report with 21 datasets(each dataset will take less than 5 sec to execute except 2 which are taking 3-4 mints),the problem is I`M able to run my report in report manager,but same report am not able to run from web application,bcoz its seems to be timeout(after running its showing blank page).We went over to optimize those sections in the script but no use. Can anybody help me to how to resolve this issue,its an urgent one.

early responses highly appreciated.

thanks, @ng

more ▼

asked Mar 20, 2012 at 05:18 AM in Default

avatar image

ANJI
14 12 14 15

@ANJI Somehow my comment got lost, so I will try it again here. Your problem might be related to the http timeout which is out of the box set to 90 seconds. DatabaseQueryTimeout which eventually get translated to the CommandTimeout of the respective Command object instance might not help if the page times out before the proc is finished executing. With async processing the proper command timeout setting allows the proc to finish but if the page itself times out before that then nothing is displayed on it. You can tweak the http timeout per application or per page. Here is the per page setting sample:

 <location path="your-report_url.aspx"> 
     <system.web>  
         <httpRuntime executionTimeout="300"/> 
     </system.web>  
 </location>  
Mar 20, 2012 at 06:20 PM Oleg
(comments are locked)
10|1200 characters needed characters left

2 answers: sort voted first

The default timeout period of "DatabaseQueryTimeout" is 120 secs i.e. 2 minutes. So seems like 3-4 minutes queries are getting time out. You can change the timeout value for "DatabaseQueryTimeout" in RSReportServer.config file according to your needs. If that does not help, then please revert as there are some other factors to look into.

more ▼

answered Mar 20, 2012 at 06:53 AM

avatar image

Usman Butt
13.9k 6 12 21

thanks usman , I`m using the SS2008R2,the option may be this setting is not available here,bcoz it says SQLCommandTimeoutSeconds--"This setting is not used". And also i tried with "Timeout" option for dataset in the report designer and "Do not time out" in the report processing option,but still its not work for me.

please consider the version 2008R2 and support me.

Thanks, @ng

Mar 20, 2012 at 08:28 AM ANJI

Did you change the value for this <Add Key="DatabaseQueryTimeout" Value="120" /> ? If you do not have this entry, then please add it. AFAIK, DatabaseQueryTimeout is the same in SSRS 2008 R2 and BOL confirms that.

Mar 20, 2012 at 08:47 AM Usman Butt

yes,even though i made it to Add Key="DatabaseQueryTimeout" Value="300" still my problem is there,mean while what i observed is my report is not rendering even 2 minutes in my application, while rendering(round green progress bar)button getting collapsed with in 2 minutes and looks like a white page.But the same report is keep on rendering in report manager and populating the data with in 3-5 minutes

Please help me is there any alternate solution to resolve these type of problem

Mar 20, 2012 at 09:25 AM ANJI

Seems like the configuration or authentication is not correct. For that you can visit BOL. Moreover, please see the log files, may be they could let you know the reason. For that you can visit this BOL link.

Mar 20, 2012 at 09:57 AM Usman Butt

Usman, I just verified the log files also i sent u the log record running the same report: first one is from Report manager second row is Web application

 TimeStart    TimeEnd    TimeDataRetrieval    TimeProcessing    TimeRendering    Source    
 45:42.5           47:20.6        93811                3853    396          Live    
 43:25.2           45:32.1        120228                3231    3222          Live    

 Status    ByteCount    RowCount
 rsSuccess    7296    687
 rsSuccess    78176    680

plz note that report is working in report manager.

plz suggest me something.

Mar 20, 2012 at 10:59 AM ANJI
(comments are locked)
10|1200 characters needed characters left

In the web.config file, adjust the time out time for the application under: < httpRuntime executionTimeout="9000" />

more ▼

answered Jan 15, 2013 at 11:04 PM

avatar image

dmedici
90 2 2 6

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x647
x106

asked: Mar 20, 2012 at 05:18 AM

Seen: 1814 times

Last Updated: Jan 15, 2013 at 11:06 PM

Copyright 2016 Redgate Software. Privacy Policy