Error: An item with the same key has already been added. 2008 R2 Nov CTP

I am getting a classic MS error "An item with the same key has already been added."

I am running 2008 R2 Nov CTP on Windows XP SP3 (VirtualPC: XP Mode in Windows 7 64 bit). I was trying to add new dataset in already existing report. While doing that BIDS is giving me this error. I've googled and found out that its a well known issue from 2005 but didn't know that this issue is not resolved completely. There is a hotfix for 2008 version 10.1.2531.0 (http://support.microsoft.com/kb/971049) . (Mine is 10.50.1352.12).

I've tried doing following.

  1. build the project couple of times. (as suggested from one site)

  2. Used text.

  3. Created stored proc with the same text.

  4. Tried to give different names for dataset as well stored proc. but no luck yet.....

Any more suggestion or fixes?....


more ▼

asked May 27, 2010 at 06:07 PM in Default

avatar image

48 3 3 5

(comments are locked)
10|1200 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.



asked: May 27, 2010 at 06:07 PM

Seen: 3487 times

Last Updated: May 27, 2010 at 06:07 PM

Copyright 2016 Redgate Software. Privacy Policy