question

Shiloy Reinhart avatar image
Shiloy Reinhart asked

.Net application invkoing a stored procedure accessing a linked server(Oracle)

Hello

I run my stored procedure that accesses the Oracle linked server from Management Studio and it works fine. When I invoke the stored procedure from my .NET application it times out. I have been googling and googling. I have set the commandtimeout command to many different times. I have also changed the connection timeout on the connection string. It seems as if it totally ignores them. I also tried " mycommand.CommandTimeout = 0". The application running live is working. I am making changes to the application. When I debug in Visual Studio I time out. WHen I deploy to a test folder on the web server I also time out. This application invokes many stored procedures and all of them work even ones accessing different servers(the difference is they are SQL not Oracle) and those are linked servers also. The only one that times out in my .NET application is the one that accesses the Oracle linked server. I have a call into the help desk for the application on that server which is administered offsite. I also have a call into a guy who is a SQL expert.

FYI: Recently our network administrator deployed a new firewall (WatchGuard).
Any Ideas ?

oraclelinked-server
4 comments
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

How is security set up for the linked server?
1 Like 1 ·
I agree with Jack. It sounds like your procedure doesn't have access to the linked server. Makes the most sense.
0 Likes 0 ·
Remote login and password supplied by the Oracle Administrators. I can run the stored procedure manually but not through the .net application. I am thinking it has to be someting stupid I am missing or doing wrong. I get SQLException was unhandled by user code. Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. thanks
0 Likes 0 ·
I just spoke with the network administrator and our firewall is only on outgoing not on internal servers so that is not the problem which I did not think was but had to ask anyway.
0 Likes 0 ·

0 Answers

· Write an Answer

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.