Unable to run a "Execute SQL Task

0 Hello!

I have had this challenge for a while while creating a project in VS 2008 Pro Edition on Windows Vista, 32 bit. And I have tried to solve it by reading through many blogs but all to no avail.

The error I got was, "Error: 0xC002F210 at Truncate Staging, Execute SQL Task: Executing the query "" failed with the following error: "Retrieving the COM class factory for component with CLSID {19E353EF-DAF4-45D8-9A04-FB7F7798DCA7} failed due to the following error: 80040154."

There are no parameters to set as the Result Set is set to '0' in the 'Execute SQL Task'. The T-sql syntax is correct as well.

I have created many project with this same VS tool lots of time in the past.

Please help.


more ▼

asked Nov 02, 2011 at 10:46 AM in Default

avatar image

11 3 4 5

does it give this same error on more than one machine?

does it also throw the error if you try to edit an existing proejct?

if you create another new project, does it do the same thing?

I presume you came across the following MS forum thread and the solution didn't work for you - http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/604b4755-db3f-4103-9659-4a944731b16a

Nov 02, 2011 at 11:01 AM KenJ

...also if you are executing this from a SQL Agent job, you may need to check/uncheck "Use 32 bit runtime" on the Execution Options tab of the job step

Nov 02, 2011 at 11:15 AM Scot Hauder
(comments are locked)
10|1200 characters needed characters left

2 answers: sort voted first

Thanks for the link. I read the content, "**This class id is for SQLTaskConnectionOleDb Class. Probably the registration is corrupt. Try this: regsvr32 "C:\Program Files\Microsoft SQL Server\100\DTS\Binn\SQLTaskConnections.dll" or on 64bit OS: regsvr32 "C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\SQLTaskConnections.dll" Give it a try and let us know how it goes."

The question is should I download regsvr32? No clear direction as to what to do. I do not get the instruction. I will be happy if you can throw more light on that. Thank you.

more ▼

answered Nov 03, 2011 at 03:10 AM

avatar image

11 3 4 5

It's an operating system command. You just open a command shell and type in the command as given - making sure you use the actual path to the .dll file on your machine.

Nov 03, 2011 at 06:34 AM KenJ
(comments are locked)
10|1200 characters needed characters left

Hello KenJ,

In an attempt to resolve the issue, I opened up my machine cmd and paste the address as told like;

C:\Users\Owner>C:\Program Files\Microsoft SQL Server\100\DTS\Binn The return was

"C:\Program' is not recognized as an internal or external command, operable program or batch file."

Or is that not what I was suppose to do? Please do direct me as to what you mean by a command shell if different from what I have done. Thank you

more ▼

answered Nov 08, 2011 at 02:15 PM

avatar image

11 3 4 5

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.



asked: Nov 02, 2011 at 10:46 AM

Seen: 1733 times

Last Updated: Nov 02, 2011 at 10:46 AM

Copyright 2018 Redgate Software. Privacy Policy