x

Troubleshoot: "Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding"

We have this virtualised(VMWare) Microsoft SQL Server 2008 (SP1) - 10.0.2531.0 (X64) build 7600, on Windows 2008 r2 Enterprise. We have this very nagging problem of "Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding" error message using SSMS just to login.

UPDATE:

We're using mixed authentication.

It only happens when connecting through SSMS remotely, but if I RDP inside and connect it doesn't happen.

I've tried connecting via IP but it also gives the same error

What I have done in hopes of resolving this issue:

  1. Reduce the number of users under the sysadmin roles(http://support.microsoft.com/kb/934751)

  2. Check, via the sysads, if firewall is blocking the port or dropping them. They said its not.

  3. Installed sp_whoisactive just to make sure there's no long running query that might contribute to this. Found nothing.

  4. Check if SQL Browser is running and is active, both are true.

  5. Disabled for the meantime CDC jobs, just to eliminate it from equation.

I'm connecting via SSMS 2008 r2/ SSMS 2008 and sqlcmd all return the same message.

I'm stumped and its intermittent , do you have any idea in troubleshooting this? *----

more ▼

asked Jun 09, 2011 at 06:32 AM in Default

avatar image

bonskijr
204 5 5 10

SQL or Windows logins being used?

Jun 09, 2011 at 06:58 AM Blackhawk-17

Sorry it's mixed logins

Jun 09, 2011 at 07:09 AM bonskijr
(comments are locked)
10|1200 characters needed characters left

1 answer: sort voted first

My first guess at this would be a DNS issue that is causing Windows Authentication difficulty in finding/communicating with the Domain Controller.

Do you get the error with a SQL login?

more ▼

answered Jun 09, 2011 at 07:23 AM

avatar image

Blackhawk-17
12.1k 30 36 42

Sadly yes, either types of authentication. Can't troubleshoot it because it's happens mostly "randomly"

Jun 09, 2011 at 07:31 AM bonskijr

Can you experiment by connecting to SQL by IP as opposed to name and see if the timeouts continue?

Jun 09, 2011 at 08:11 AM Blackhawk-17

I also did that, as my initial thought was a DNS issue.

Jun 09, 2011 at 08:20 AM bonskijr

Do you have multiple IP addresses? On a VLAN? Saturated network?

Sounds like Shared Memory works but TCP/IP has issues.

Jun 09, 2011 at 10:16 AM Blackhawk-17
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x2175
x159
x21

asked: Jun 09, 2011 at 06:32 AM

Seen: 7614 times

Last Updated: Jun 09, 2011 at 08:27 AM

Copyright 2017 Redgate Software. Privacy Policy