Restore of full database backup

Today I faced a problem of restoring database backup, consist about 20GB, before a week, I restored backup simple and fast as usually, today it takes hours and hours to restore, what can be problem in here?
I faced some errors like: FCD::Cannot open file..

more ▼

asked May 05, 2011 at 01:07 AM in Default

avatar image

323 24 26 31

Has your underlying storage changed?

May 05, 2011 at 01:13 AM ThomasRushton ♦♦

Nothing changed form previous situation, norupdate where installed

May 05, 2011 at 01:15 AM Gogolo

do you use a 3rd party backup solution or is this a native backup?

May 05, 2011 at 01:16 AM Fatherjack ♦♦

its a native backup

May 05, 2011 at 01:17 AM Gogolo

is it a physical or virtualised server?

May 05, 2011 at 01:20 AM Kev Riley ♦♦
show all comments (comments are locked)
10|1200 characters needed characters left

4 answers: sort voted first

From all the other comments it sounds like your RAID array is taking a hit. Is Drive C: a different array, possibly RAID 10, then you have another set of disks for D: and F:. When I first started reading your post I was thinking maybe you had a bad drive and the array was having to rebuild a spare, but with the errors you are getting trying to write to the disk makes me think you have bad sectors. I would recommend running a scan disk on the drive to rule that out. Are you pretty familiar with RAID and can look at the RAID Manager software to check for errors? If not get your systems guy to take a look. Windows Event Viewer might also contain some good information as to what is going on with the disk subsystem.

more ▼

answered May 05, 2011 at 05:39 AM

avatar image

40.9k 39 95 168

As per information, drives are in RAID 5

May 05, 2011 at 05:53 AM Gogolo

Operating system is RAID1, and storage its RAID5, also operating system is mirror.

May 05, 2011 at 06:06 AM Gogolo

Since you can restore to C: your backup file is good. The errors you are getting is trying to write to D: and F: which wreaks of corruption on your RAID 5 array. Is your database even accessible or is it having issues which is what is causing you to have to restore from backup? Your RAID management software should have more information about the root of the error and quite possibly the windows event log. Do you have physical access to the server to see if you have amber lights on the disks? I assume this is local raid with hot swap drives.

May 05, 2011 at 06:07 AM Tim
(comments are locked)
10|1200 characters needed characters left

OK Comment list getting a little long.....

Can you confirm that the file does actually exists in the location you think it is?

Could there be any other process accessing the file (NAS/disk/tape backups, anti-virus scans, etc)?

Is the backup from the same server that it is being restored on or another server?

more ▼

answered May 05, 2011 at 01:36 AM

avatar image

Kev Riley ♦♦
66.8k 48 65 81

There's no other backup restore on server, and for accessing process I'm not sure, There is a McAfee installed on server.

May 05, 2011 at 02:26 AM Gogolo

Check the McCafee settings and verify it is not set to scan the D: and F: drives and that real-time scanning is disabled.

Running anti-virus on a database server can be problematic and takes some extra configuration.

May 05, 2011 at 04:54 AM KenJ
(comments are locked)
10|1200 characters needed characters left

Can you write files to the locations given in the error messages? D: and F: would appear to be the target drives...

more ▼

answered May 05, 2011 at 02:52 AM

avatar image

ThomasRushton ♦♦
42.4k 20 60 54

Yes, I can write in that locations, but it takes too long.. Ex. for restore which before a week.. toked 10 min, now I need 2-3 h

May 05, 2011 at 03:07 AM Gogolo

What are D: and F: - are they local drives to the server, drives on a SAN?

May 05, 2011 at 03:09 AM Kev Riley ♦♦

Yes sir, they are local drives in same server.

May 05, 2011 at 03:16 AM Gogolo

Are D: and F: on the same physical drives? If they are an array, have you checked that the array is in good order? If it has lost a drive and is rebuilding the IO will suffer. Check the hardware is in good order

May 05, 2011 at 03:20 AM Fatherjack ♦♦

You might also want to check the state of the drive / array controller. And make sure that all drivers are up-to-date. It definitely feels like something's not happy at the storage / IO level.

May 05, 2011 at 04:10 AM ThomasRushton ♦♦
(comments are locked)
10|1200 characters needed characters left

Based on the errors it looks like you are trying to restore to the root of the drives.

Create folders on the drives to restore into and ensure that the SQL Server service has full NTFS access permissions.

more ▼

answered May 05, 2011 at 05:01 AM

avatar image

12.1k 30 36 42

I restored on C drive and goes very well, that means I have problem with RAID!?? (Server is not clustered)

May 05, 2011 at 05:15 AM Gogolo

@Gogolo - that is a possibility. Are you seeing any events in the Windows logs or in the Array logs?

Have you tried my suggestion? It is to determine if permissions are a factor. By changing your restore to C: you have identified that there is an issue on the other drives but not what it is yet.

May 05, 2011 at 05:19 AM Blackhawk-17

Yeah I understand, I tried your suggestion, but looks like everything is OK with permissions.

May 05, 2011 at 05:51 AM Gogolo
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.



asked: May 05, 2011 at 01:07 AM

Seen: 1854 times

Last Updated: May 05, 2011 at 02:55 AM

Copyright 2018 Redgate Software. Privacy Policy