question

Noonies avatar image
Noonies asked

How can I change the local SQL Instance Name from \\.pipe\... ?

I have a SQL instance that had been installed not by me and when connecting from the server the instance was created on, I have to connect using \\.pipe\... instance name. When I connect from a workstation having SSMS installed I can user the SQL instance name of \. I would like to be able to connect from the local server to the local database using the SQL instance name of \. Does anyone know how I can make this change? Also, what caused this set up?
sqlserver-instances
4 comments
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

It the instance the "default" instance?
0 Likes 0 ·
@Jonlee Lockwood - I believe that it is the only instance installed. A web developer had installed SQL Express but a server admin installed SSMS 2008 R2. The instance I connect to is named with SQL Express. I'm pretty sure this would be a default instance. Is there a way to tell or a place I could look to see how many instances they may have created on the server and which one is the default?
0 Likes 0 ·
@Jonlee Lockwood - Thank you! I will check when I'm back in the office on Monday. I will come back and let you know.
0 Likes 0 ·
@Jonlee Lockwood - The default instance is (SQLEXPRESS) but when connecting locally I have to put in this long path \.pipeMSSQL$SQLEXPRESSsqlquery which I find in the SQL Server Config Manager under the Named Pipes - Pipe Name. I will take a look at your link but wanted to respond to the default instance question you had asked.
0 Likes 0 ·

1 Answer

· Write an Answer
sp_lock avatar image
sp_lock answered
@noonies, the easiest wat is to check the services.msc... If it isnt a default instance, check the browser service and you have TCP enabled. http://msdn.microsoft.com/en-us/library/ms181087%28v=SQL.100%29.aspx
1 comment
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@JonLee Lockwood - Thank you for the link you provided! I logged into the server and set port to 1433 and the connection works perfectly. I can now connect using /
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.