question

chana avatar image
chana asked

Robocopy very slow in sql

we use robocopy to transfer a huge folder from one server to another.Since last few week my robocopy which work using sql take double times. can i know why how to solve it .
administrationrobocopy
3 comments
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

@chana - just a note - this is a SQL Server site. While we are glad to help, we want to try and keep the questions "on topic". Robocopy, even when used together with SQL Server, is quite "off topic" in my opinion. Questions on non-SQL Server Admin are better asked over at [serverfault][1]. [1]: http://serverfault.com
3 Likes 3 ·
Unless the RoboCopy job is run as a SQL Agent job :)
0 Likes 0 ·
@Blackhawk - granted, but still - copying files over a network has little bearing on sql server IMO
0 Likes 0 ·
WilliamD avatar image
WilliamD answered
It will porbably have nothing to do with SQL Server. There are many reasons for a copy job running slow, these are just a few: - Are the files/folders getting larger? - Is your network running at full capacity? - Are your disks on target or source being used heavily? - Are you copying one large file/folder or lots of small files? - Is someone else using your target/source machine and thus contending for resources?
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

TimothyAWiseman avatar image
TimothyAWiseman answered
WilliamD has some very good points. I especially would call attention to his first two bullets. But I think I can add one that is at least worth looking at. Robocopy is very often set to exclude files, for instance it may exclude those without the archive bit set (/A or /M) or else exclude older files (/XO). It could be that a large amount of data in files that were being excluded are now being included, perhaps because they are being modified more often now which will usually make them considered newer and set the archive bit.
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

catherinelee99 avatar image
catherinelee99 answered
Well, I didn't had this problem in SQL but in live server and it soon became a mess. The funny part is when I enabled its multi threaded file transfer it got even slower. I tried everything to fix it and nothing helped. Then my friend told me about GS Richcopy 360 which has 100% multi threaded file transfer. Now my problem is fixed and I am happy with its performance. Maybe you should now shift to some other software. Thanks!
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.