question

rwilliamz avatar image
rwilliamz asked

Trouble running copy database command in SQL 2008

I'm trying to understand why the copy database command is not working. I'm in SSMS directly on the db server, I setup the copy job, using (local) as the source and destination, with sa login selected for each. This works fine on my local dev machine setup.

Event Viewer reports:

Login failed for user 'sa'. Reason: Password did not match that for the login provided. [CLIENT: <local machine>]

But, I know I have the right password.

This is on Windows Server 2008 with SQL Server 2008. Both the SQL Server and SQL Server Agent services are running under a non-system account (one that was setup when SQL was installed).

Any ideas for what to look at?

sql-server-2008backup
1 comment
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I've tried using both authentication methods and both transfer methods, but no luck.
0 Likes 0 ·

1 Answer

· Write an Answer
RickD avatar image
RickD answered

Are you sure you aren't using the password for your dev machine rather than this machine?

Can you create a connection in Management Studio for each server using sa (you shouldn't really use sa, but guess you know that)?

Arte you sure you have the passwords the right way around for each server? i.e, you're not putting your dev machine password into the other server and vice versa.

10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.