question

Cyborg avatar image
Cyborg asked

Linked Server Error : The partner transaction manager has disabled

Hi all, I have 2 Servers, ServerA and ServerB. I have configured a ServerB as a Linked Server on ServerA (Both as SQL 10). The developers created a Stored procedure inside ServerA called usp_ServerA in which they are trying to execute ServerB Procedure inside a transaction. When they execute the ServerA Procedure ie. usp_ServerA they are getting an error "OLE DB provider "SQLNCLI10" for linked server "ServerB" returned message "The partner transaction manager has disabled its support for remote/network transactions.". error" But when i removed the transaction inside ServerA Procedure ie usp_ServerA, it works fine. When i used the transaction it throws the error. Is the problem is because of DTC? I have configured the MC DTC correctly. DTC Service is also running.
serverlinked
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Tim avatar image
Tim answered
Go to "Administrative Tools > Component Services" - On the left navigation tree, go to "Component Services > Computers > My Computer" (you may need to double click and wait as some nodes need time to expand) - Right click on "My Computer", select "Properties" - Select "MSDTC" tab - Click "Security Configuration" - Make sure you check "Network DTC Access", "Allow Remote Client", "Allow Inbound/Outbound", "Enable TIP" (Some option may not be necessary, have a try to get your configuration) Also make sure the "Distribute Transaction Coordinator" Service is running on both servers. Hope this helps.
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I have configured the MC DTC correctly. DTC Service is also running.
0 Likes 0 ·
WilliamD avatar image
WilliamD answered
Can you check that the linked server setup to allow distributed transactions?
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Yes I Checked, it is enabled : Enable Promotion of Distributed Transaction = True
0 Likes 0 ·
Cyborg avatar image
Cyborg answered
Hi all Thanks for your comments, Its my bad! Ally my MS DTC settings was correct except thee "Enable TIP option" I enabled it, there after its working fine
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Glad you got it working, that was in my suggestion above.
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.