question

Felipe Silva avatar image
Felipe Silva asked

Problem with linked server - sql 2008

Friends, I Have a problemn. I cant configure Linked server to other sql server. I received the following error? A transport-level error has occurred when receiving results from the server. (provider: Shared Memory Provider, error: 0 - The pipe has been ended.) (.Net SqlClient Data Provider) Windows server 2003 R2 Standandard SQL Server 2008 Standandard I believe that is a imcopatibility between SQL 2008 and Windows 2003 R2. Can anyone help me??
sql-server-2008linked-server
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Grant Fritchey avatar image
Grant Fritchey answered
No, it means you're trying to connect using the Shared Memory Provider which is probably not possible unless you're trying to connect to a different instance on the same machine. Check your set up. You probably need to enable, on a guess, TCPIP to get the right connection.
5 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Grant Fritchey avatar image Grant Fritchey ♦♦ commented ·
Assuming you're using TCP like everyone else, I wouldn't bother with named pipes or shared memory. I usually disable named pipes in fact. Make sure the protocols are enabled on both servers. Make sure the second server allows remote connections. Check the connection string to be sure you have it right. Are you using SQL Native Client or SQL OLEDB Provider? I usually use the Native Client. It's easier to set up. You just need the server & instance name.
1 Like 1 ·
Felipe Silva avatar image Felipe Silva commented ·
I trying to connect a different instance. The protocols TCP/IP, Named Pipes e Shared memory was enable in SQL Configuration Manager. What can i do?
0 Likes 0 ·
Felipe Silva avatar image Felipe Silva commented ·
I use sql native client. There are other server that can connect second server. The login configured in linked server was sysadmin;
0 Likes 0 ·
Grant Fritchey avatar image Grant Fritchey ♦♦ commented ·
That's probably not a real login. You need to set up security using a known acccount.
0 Likes 0 ·
Felipe Silva avatar image Felipe Silva commented ·
I used sa account. It has the same psasword in all servers.
0 Likes 0 ·
Matt Whitfield avatar image
Matt Whitfield answered
A workaround is probably to go with TCP/IP as Grant says, but I don't believe you are actually doing anything wrong - I think you've stumbled across a bug. One suggestion I would have is to check the event log on the server to check for any events being logged at the same time as your error. As an aside, I stumbled across this KB article while digging for info, which has the most scary list of possible side-effects for an ALTER TABLE statement - ever! : [ http://support.microsoft.com/kb/916780][1] [1]: http://support.microsoft.com/kb/916780
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Felipe Silva avatar image Felipe Silva commented ·
I formated the server, reinstall sql server, configured the linked server (the same way) and work correctly. I think this is a any configuration on server, but i dont know what configuration. Anyone can help me?
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.