question

ipeoples avatar image
ipeoples asked

How to grant schema permissions?

I created a new schema in SQL and created new tables under the new schema.(dev,cc_table) The problem is that I cant load data into those tables because I receive the error message below. If I change the schema (dbo.cc_table) I have no problems loading data.

An OLE DB record is available. Source: "Microsoft SQL Server Native Client 11.0" Hresult: 0x80004005 Description: "Could not allocate a new page for database 'Development' because of insufficient disk space in filegroup 'PRIMARY'

sql-serverschema
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

· Write an Answer
JohnM avatar image
JohnM answered

This isn't about schema permissions. The file group is full so you need to add disk space or clear out objects/data to allow space within the data file to grow. If disk space is available, look at the file settings to see if auto-growth is disabled or the limit was set to a low value.

10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.