question

esege avatar image
esege asked

Local database problem

I installed sql server 2016 sp1 and sql server management studio on my windows 10 pc. When i write "sqllocaldb versions" i get "Windows API call "RegGetValueW" returned error code: 0.". When i write "sqllocaldb create "locall"" i can find the 'locall' directory under the C:\Users\'user'\AppData\Local\Microsoft\Microsoft SQL Server Local DB\Instances but i cannot see locall in sql management studio. How can i fix that?
databasesql-server-2016management-studio
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jason_clark03 avatar image
jason_clark03 answered
you may enable TCP/IP or Named pipes for named connections if not enables then enable it then try ..
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

jason_clark03 avatar image
jason_clark03 answered
In SQL Server Configuration Manager (type in Start menu). Click on SQL Server Services. Instance name is in parenthesis inline with SQL Server service. If it says MSSQLSERVER, then it's the default instance. To connect to it in Management Studio, just type . (dot) OR (local) and click Connect. In your condition as your instance name is different, then use .\[instance name] to connect to it (.\locall). Also, check SQL Server and SQL Server Browser services are running, you won't be able to connect of they are not running
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.