question

liton avatar image
liton asked

Unable to Modify agent job on Remote Server

I'm unable to modify the the SQL Agent job when I login to the Remote Desktop where the SQL Server is installed but I'm able to modify the same job when I connect via my local machine. Is there a setting that needs to be changed on the server where SQL Server is installed?
agent
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

·
David Wimbush avatar image
David Wimbush answered
It sounds like you're not using the same credentials. Are you logging into the server with the same credentials you use on your local machine? Are you using the same credentials in SSMS?
6 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Yes, I'm using the same credentials. My credential in my local machine is different (different domain) but I'm opening/running the SSMS using the same credential as the remote server. When I created the job, I transferred the job to another user but I assume that shouldn't matter since I'm able to modify the job in my local machine.
0 Likes 0 ·
I don't think the owner of the job makes much difference. As far as I know you can change any job as long as you have the right persmissions on the server. If you're connecting using the same credentials in SSMS on the server that you use in SSMS on your local machine, I can't see why it doesn't work on the server. Could it be UAC? On the remote desktop, try right clicking on SSMS and choosing Run As Administrator. Does that help?
0 Likes 0 ·
Yes, that is the case. Thanks for the help. Is there a way to resolve this other than opening as Administrator each time? All the people are having the same issue so if there's no other solution then I will have to tell everyone to Run SSMS as Administrator.
0 Likes 0 ·
You could resolve this by having them connect using SSMS from their own machine. The less they log into the server interactively, the less chance that something important will be accidentally changed. It will probably save them time, too, since they won't have to go through the remote desktop/windows login process when they need to make these changes.
0 Likes 0 ·
Technet has instructions on configuring an app to always run as administrator - https://technet.microsoft.com/en-us/magazine/ff431742.aspx To mark an application to always run as an administrator, do the following: 1. On the Start menu, locate the program that you want to always run as an administrator. 2. Right-click the application’s shortcut, and then click Properties. 3. In the Properties dialog box, click the Compatibility tab. 4. Do one of the following: To apply the setting to the currently logged-on user, select the Run This Program As An Administrator check box, and then click OK. To apply the setting to all users on the computer and regardless of which shortcut is used to start the application, click Change Setting For All Users to display the Properties dialog box for the application’s .exe file, select the Run This Program As An Administrator check box, and then click OK twice.
0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.