question

KenJ avatar image
KenJ asked

Why is my edited answer "waiting approval by a moderator"

I answered this question a couple days ago - https://ask.sqlservercentral.com/answers/134496/view.html It's been out there a while and received a couple of votes. Today I edited the answer when I noticed I had used "redo" rather than "undo" in one place. The answer was then flagged "The answer is waiting approval by a moderator. " and is no longer displayed with the question. The question no longer shows that it has an answer. Any ideas as to what is going on?
site-admin
6 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

KenJ avatar image KenJ commented ·
Looking at this question on the meta site, I see that double quotes in a question aren't rendered properly. They come across as `"` (ampersand, octothorpe, thirty-four in case the escaped characters didn't render properly)
0 Likes 0 ·
ThomasRushton avatar image ThomasRushton ♦♦ commented ·
I've approved your edits. I've noticed you (and a few other notables) in the moderator pile a couple of times. I suspect that the spam filters are now being too aggressive, but I don't have the necessary knowledge to tackle it. I shall therefore hail the mighty ZomDa, and see if he's got any bright ideas. Not that I can put his nickname into a comment, goodness me, no. Bah.
0 Likes 0 ·
Kev Riley avatar image Kev Riley ♦♦ commented ·
Thank you @KenJ I had never heard of octothorpe before. I learn stuff every day!
0 Likes 0 ·
KenJ avatar image KenJ commented ·
One of those obscure words - I don't even recall where I picked it up. Glad to pass it on, though :)
0 Likes 0 ·
Tom Staab avatar image Tom Staab ♦ commented ·
Octothorpe is a new one for me too. I had to look it up. I just got the "waiting for approval" message myself while answering a simple question about service packs. https://ask.sqlservercentral.com/answers/134608/view.html
0 Likes 0 ·
ThomasRushton avatar image ThomasRushton ♦♦ commented ·
And it's out of the moderation queue... for now... It seems to be that even editing a question/answer will put it back into the moderation bin...
0 Likes 0 ·

1 Answer

·
DaveC avatar image
DaveC answered
I've put in a ticket about the double quotes. I think this question was caught because there's a limit on the number of times the same pair of words can appear before a comment is flagged for moderation (as it's a common spam pattern). In this case I think it was the repeated use of "uncommited transactions" that pushed it into moderation. I've upped the limit of repeated phrases required to trigger moderation, I'll keep an eye on it to see if it's letting more spam through.
4 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

ThomasRushton avatar image ThomasRushton ♦♦ commented ·
Is it possible to adjust the spam filter so that posts from more... trusted users are more leniently treated?
1 Like 1 ·
Tom Staab avatar image Tom Staab ♦ commented ·
LOL, Thomas. I came over here to ask that exact question. In fact, I'm going to raise it as a new question. I just had to approve an answer from Magnus. I think it's safe to assume we can trust him. After all, he only has 19.4k karma points right now. :)
1 Like 1 ·
DaveC avatar image DaveC ♦♦ commented ·
It's not part of the spam filter - it's triggered by things like posting multiple questions in <2 minutes, repeating the same phrase more than a set number of times, and certain trigger words. There's no whitelisting in the current version, but I'll request it.
1 Like 1 ·
KenJ avatar image KenJ commented ·
Thanks! The filter makes sense - especially in light of all the recent 'university' posts
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.