question

vivekchandra09 avatar image
vivekchandra09 asked

Using sa cannot connect to sql server

My coworker can connect to sql server using sa password. However, I can not do it. I get an error (Provider: Named Pipes Provider: error :40 - could not open a connection to sql server)(Microsoft Error: Error :53)
sql-server-2008-r2error-message
3 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vivekchandra09 avatar image vivekchandra09 commented ·
OK I resolved it. Thanks for your comments.
0 Likes 0 ·
Show more comments
vivekchandra09 avatar image vivekchandra09 commented ·
The password was little complex to memorize for me.
0 Likes 0 ·

1 Answer

·
JohnM avatar image
JohnM answered
Do you have TCP/IP enabled for the native client? If you look under Start, Programs, SQL Server 2008 R2, Configuration Tools, SQL Server Configuration Manager you can adjust the protocols for the native client. I would imagine that you have TCP/IP disabled and Named Pipes enabled. Enable TCP/IP and then try the connection again. Hope that helps.
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

vivekchandra09 avatar image vivekchandra09 commented ·
So I went to SQL Server Configuration Manager on my laptop and see three things: Shared Memory TCP/IP Named Pipes All of the three are enabled. I tried disabling Named pipe but won't work.
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.