x

SSIS Trying to Import Excel Spreadsheet Fails With Error

Hi,

I created a Data Flow Task, added an Excel Source into the task and configured to point to the Excel spreadsheet source. Added an OLE Destination and joined the source to the destination. Upon trying the execute the task it fails with the following error:

Error: 0xC020801C at Data Flow Task, Excel Source [2]: SSIS Error Code DTS_E_CANNOTACQUIRECONNECTIONFROMCONNECTIONMANAGER. The AcquireConnection method call to the connection manager "Excel Connection Manager 2" failed with error code 0xC0209303. There may be error messages posted before this with more information on why the AcquireConnection method call failed.

Has anyone seen this error before or have an ideas why it maybe failing?

TIA

more ▼

asked Jan 22, 2015 at 05:25 PM in Default

avatar image

David 2 1
1.2k 56 61 67

Do you have the Excel file open somewhere?

Jan 22, 2015 at 05:43 PM JohnM

Thanks. Managed to resolve it below.

Jan 22, 2015 at 05:49 PM David 2 1

Perfect. Please go ahead and mark your answer as the accepted one so that others know that you found the solution. Thanks!

Jan 22, 2015 at 05:53 PM JohnM

I've got the project to execute correctly from Visual Studio 2010 however after successfully building and deploying the project to the SSISDB catalog I cannot execute it from there. "Error:The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine." Any ideas? TIA

Jan 23, 2015 at 05:09 PM David 2 1
(comments are locked)
10|1200 characters needed characters left

2 answers: sort voted first

Project >> Properties >> Configuration Properties >> Debugging and changed Run64BitRuntime to False resolved my issue.

more ▼

answered Jan 22, 2015 at 05:45 PM

avatar image

David 2 1
1.2k 56 61 67

(comments are locked)
10|1200 characters needed characters left

This issue is occuring because you are having a 64 bit OS and Office Excel (including most of the office products) does not have 64bit provider and hence the error above on Excel connection.

You can solve this issue by setting Run64BitRunTime property as False

Go to properties page for the overall SSIS solution, simply set the Run64BitRunTime = False.

more ▼

answered Mar 21, 2016 at 08:42 AM

avatar image

arajmsbi
1 2

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x1212
x148
x126
x71

asked: Jan 22, 2015 at 05:25 PM

Seen: 7589 times

Last Updated: Mar 21, 2016 at 08:42 AM

Copyright 2017 Redgate Software. Privacy Policy