question

childebrand avatar image
childebrand asked

SQL Server file association changed

Some how I change the SQL server data file type "MDF" association from SQL Server Database Primary Data File (.mdf) to Notepad. Does any one know how to change back? Thanks
sql servermdf
2 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

DenisT avatar image DenisT commented ·
Which Windows version are you using?
0 Likes 0 ·
VishalhSingh avatar image VishalhSingh commented ·
do you mean you changed the file extension? or all together you selected a different file (with txt extension)?
0 Likes 0 ·

1 Answer

·
raadee avatar image
raadee answered
Hold down shift + right click on a .mdf file, choose "open with" and "Choose default program". In the open with dialogue you need to select the .ico file for mdf files. In my case the file is in: C:\Program Files (x86)\Microsoft SQL Server\90\Shared\mdf_ndf_dbfiles.ico When you select the .ico file you will get an error, but the icons for the .mdf files are changed. Other OS's might have a little different options for the open with dialogue but it should roughly be the same.
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.