question

UnishSQL avatar image
UnishSQL asked

System Databases are missing!!!!!!

[1]My system database became invisible .I am not able to see system Databases in my instance. I have SYSADMIN rights on my instance and my instance is working good [1]: /storage/temp/1735-capture123.png
sql-server-2008sql-server-2008-r2sql-serversystem-databases
capture123.png (14.5 KiB)
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

raadee avatar image
raadee answered
1. Start management studio 2. Go tools-options-environment-general 3. Remove selection for "Hide system objects in Object Explorer" 4. Restart Management Studio 5. System databases are now visible
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Yes i just got it @radee Thnku
0 Likes 0 ·
Magnus Ahlkvist avatar image
Magnus Ahlkvist answered
If the instance is working, I'm quite confident you also have system databases running. What if you run the query SELECT * FROM sys.databases ?
2 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

ya its working fine but iam not able to see System databases @magnus
0 Likes 0 ·
above image can make u understand my problem
0 Likes 0 ·
SQLGoooRooo avatar image
SQLGoooRooo answered
Step One and Two are shown in pictures below. Please ensure you have that check box DESELECTED. System databases will re-emerge. ![Step One and Two are shown in pictures below. Please ensure you have that check box DESELECTED. System databases will re-emerge.][1] [1]: /storage/temp/1741-step2.png

step1.png (28.8 KiB)
step2.png (40.8 KiB)
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Go to TOOLS then OPTIONS then ENVIRONMENT then STARTUP then deselect the "Hide system objects in Object Explorer."
0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.