question

GPO avatar image
GPO asked

Apparent SSMS 2014 SHIFT+TAB functionality change

I've just switched from SSMS 2008R2 - 10.50.2500.0 to SSMS 2014 - 12.0.2000.8 and I've noticed for my own peculiar "text editor" option settings, that SHIFT + TAB (and the decrease indent icon) take it upon themselves to reformat my code by trying to align the leftmost character of of each line to the nearest tabstop position. This does not happen for what seem to be the same settings in SSMS 2008R2. My settings in both versions are: - Indenting: None - Tab: Tab size: 8; Indent size: 8; Insert spaces - Text Editor > All languages > Settings > Enable virtual space. Here's an example (before SHIFT-TABBING): SELECT b.lah FROM bl.ah b WHERE b.lah = 'blah' and b.ladeblah = 5 ...and after SHIT+TABBING (2014): SELECT b.lah FROM bl.ah b WHERE b.lah = 'blah' and b.ladeblah = 5 ...and after SHIFT+TABBING (2008R2) SELECT b.lah FROM bl.ah b WHERE b.lah = 'blah' and b.ladeblah = 5 Does anyone know how I can stop this happening. It's supremely annoying. Oh... and please don't post commentary about the relative aesthetic virtues of the various syntax alignments. That's beside the point. At least I hope it is.
ssmsformattingshortcut-keykeyboard
3 comments
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I don't have a good answer on this. To my knowledge, your stuck with how the editor works.
1 Like 1 ·
Arrgh! :-(
0 Likes 0 ·
Oh boy. I just noticed my Freudian typo. Oops! It's probably a more accurate description anyway.
0 Likes 0 ·

1 Answer

· Write an Answer
cesarf avatar image
cesarf answered
After entering sqlcommunity (SSMS developers) to report the issue, I've found a MS Connect forum and then a SSMS configuration page in MSDN. Try this: SSMS | Tools | Options | Tex Editor | All Languages | Tabs | Indenting | NONE SSMS | Tools | Options | Tex Editor | All Languages | Tabs | Tab | 8 SSMS | Tools | Options | Tex Editor | All Languages | Tabs | Indent | 4 SSMS | Tools | Options | Tex Editor | All Languages | Tabs | Keep tabs The only downside is you will need to adapt to the new 4 chars indentation. I mean, do this: Do new settings, create a new query tab, type any text and press home to go to beginning of line Then type tab several times and instead the usual 8 chr tabs every time... Now you'll see indentation as 4 spaces / 8 chr tab / 4 spaces / 8 chr tab... This is useful, but also a little different than ANY OTHER text editor Personally, I don't like computer forces me to CHANGE my standard gui behavior, specially after 37 years coding Anyway, I hope this helps.
10 |1200 characters needed characters left characters exceeded

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.