question

ancoleuterio avatar image
ancoleuterio asked

SSRS Slower in Server than in MSVS

Hi, I created a report that runs in less than 2 seconds in MSVS. I deployed the report in our report server and it takes about 15 seconds for it to complete. The report is only returning about 700 rows. It uses 2 parameters that have default values when you open the report. The stored procedure that is used for the dataset contains 2 parameters: reporttype and office locaton. it also has if statements within the stored proc. I already declared local parameters in the report for parameter sniffing. pls help
ssrs-2008-r2
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

This site runs off of votes. Please mark all helpful answers by clicking on the thumbs up next to those answers. If any one answer lead to a solution, please indicate that by clicking on the check mark next to that answer.
0 Likes 0 ·
Pavel Pawlowski avatar image
Pavel Pawlowski answered
Had to say where the problem can be without further details, but you can start by analyzing below views in the report server database: [dbo].[ExecutionLog] [dbo].[ExecutionLog2] [dbo].[ExecutionLog3]. Especially you can focus on below fields to identify where the issue can resist: **[TimeDataRetrieval]** - Time it took to retrieve the data from database **[TimeProcessing]** - Time it took to process the report (eg. grouping, filtering on report side etc) **[TimeRendering]** - Time it took to finally render the report. Additional infor also available on MDSN: [Report Server Execution Log and the ExecutionLog3 View][1] [1]: http://technet.microsoft.com/en-us/library/ms159110.aspx
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

I ran executionlog2 already and these were the results. [TimeDataRetrieval] - 58 [TimeProcessing] - 78 [TimeRendering] - 433 [ByteCount] - 808399 [RowCount] - 687
0 Likes 0 ·
ancoleuterio avatar image
ancoleuterio answered
So I found the culprit. It was loading a while because is set the interactivesize height to 0. i did this to display the whole report on one page. When I set it back to 11in it loaded fast enough. Is there a way to display the whole report without using the interactivesize height property???
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.