x

SSRS subreport with stored procedure (2008 R2 database)

Hi,

I have a similar problem to:

http://ask.sqlservercentral.com/questions/108774/using-stored-procedure-with-parameters-in-ssrs-and.html

I have set up the parameters in the subreport (these actually came across when I mapped to the stored procedure). They are visible, and the report runs fine when I view it in its own right. However, when I set it up as a subreport, (mapping the parameters from the parent to the subreport using those from the parameter list), the parameters don't carry to the subreport. I get the error:

Data Retrieval failed for Subreport

The parameters are the same for both reports (except for one additional one that I am linking from the parent dataset). They have the same names, and have been matched correctly. I tried entering values for the subreport parameters, and these aren't getting through.

Any suggestions?

more ▼

asked Jan 14, 2014 at 06:07 AM in Default

avatar image

jkeys
11 1 1 1

(comments are locked)
10|1200 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x681
x471
x14

asked: Jan 14, 2014 at 06:07 AM

Seen: 755 times

Last Updated: Jan 14, 2014 at 06:07 AM

Copyright 2016 Redgate Software. Privacy Policy