question

rmahon avatar image
rmahon asked

SSIS Deployment Error

I am getting the following error: Storing or modifying packages in SQL Server requires the SSIS runtime and database to be the same version. Storing packages in earlier versions is not supported. I have not made any changes to my environment. I am using VS 2008 - Microsoft SQL Server Integration Services Designer Version 10.50.4000.0 and SQL Server - Microsoft SQL Server 2008 R2 (SP2) - 10.50.4000.0 (X64) Jun 28 2012 08:36:30 Copyright (c) Microsoft Corporation Enterprise Edition (64-bit) on Windows NT 6.1 (Build 7601: Service Pack 1) Both are 64-bit but I keep getting the error! I am in an urgent need to get the package changes deployed and cannot. Any assistance is much appreciated. Rob
sql-server-2008ssisssis error
7 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

KenJ avatar image KenJ commented ·
Is the SSIS runtime on the server the same patch level as the SQL server?
0 Likes 0 ·
rmahon avatar image rmahon commented ·
Ken, thanks for the reply. Not sure how to get the runtime version from the server. Can you assist?
0 Likes 0 ·
KenJ avatar image KenJ commented ·
From management studio you can connect to Integration Services on your server. It should have the version information in Object Explorer
0 Likes 0 ·
rmahon avatar image rmahon commented ·
Not at my new job...LOL. I used to have full rights to everything...server, etc. I cannot connect to IS from Management Studio.
0 Likes 0 ·
rmahon avatar image rmahon commented ·
Ok. I was able to get the network guys to look and they came back with ssis is at 10.50.1600 an database is at 10.50.4000. That is my problem then, correct?
0 Likes 0 ·
KenJ avatar image KenJ commented ·
It looks like it. SSIS is unpatched on the RTM build and the database engine is on SP2.
0 Likes 0 ·
rmahon avatar image rmahon commented ·
Thanks Ken, for the help troubleshooting this.
0 Likes 0 ·

1 Answer

·
KenJ avatar image
KenJ answered
Your SSIS runtime has not been patched: it's still RTM. Your SQL Server is on SP2. If you update SSIS to SP2, you should be able save the packages to the server.
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.