x

Problem with SQL Server on DC

I have 3 servers ,I create a domain controller on [DC] server. I joned 2 servers [Node11] and [Node2] with [DC] ,I used the same user [mirrusr] that is member in [Domain User]and [Domain Admins] to connect these 2 servers to the zone metamanager.local. on [DC]

I installed SQL Server 2005 on [Node11] and [Node2] with domain user account I Enabled the local and remote connections options and run the SQL SQLBrowser service.

from [Node1] server If I go to [Browse For Server] Page and click on [Network Service]..the page return me local database engine...How Can I see the database Engine from [Node2] on [Node1]... Please Pleae any idea any hint...
more ▼

asked Nov 10, 2012 at 02:37 PM in Default

Troy_2012 gravatar image

Troy_2012
750 22 35 39

@Troy_2012 - fancy giving Tim the credit for all his hard work helping you out by clicking the tick to the left of his answer please? It will show others that the answer worked for you. Also, please try to use the Comment feature rather than adding new answers when you get responses to a question you pose. It keeps the threads a little more readable. thanks.
Nov 10, 2012 at 08:30 PM Fatherjack ♦♦
Since @Troy was providing screenshots he would have actually needed to edit his on question with updated sections since you cannot add screenshots in a comment.
Nov 11, 2012 at 04:05 AM Shawn_Melton
@shawn_melton - fair point Shawn. Do you think that adding images to comments is a feature worth requesting from the developers?
Nov 11, 2012 at 09:21 AM Fatherjack ♦♦
@Fatherjack I could be mistaken, but I want to say that has been brought up before. It might be one of those "nice to have" features.
Nov 11, 2012 at 09:31 AM Shawn_Melton
(comments are locked)
10|1200 characters needed characters left

1 answer: sort voted first

On either of the nodes when you open SSMS and chose to connect to server, you can specify the name of the server to connect to, either node1 or node2. You do not have to rely on [browse for server]. This is usually never a good idea if you have many servers in your domain as it can 1) take some time to refresh, 2) is not always all exclusive.

more ▼

answered Nov 10, 2012 at 02:42 PM

Tim gravatar image

Tim
36.4k 35 41 139

Check to make sure that TCP/IP is enabled in Surface Area Connection and that the ports SQL is using are allowed in your firewall. Let me know if you need help with either of those.
Nov 10, 2012 at 02:48 PM Tim
You turned it off for Domain, but it is still active for Private and Public profiles. This could still be an issue. Can you check in the network properties in Server Configuration to ensure that TCP/IP is also enabled?
Nov 10, 2012 at 03:02 PM Tim
Start > Programs > Microsoft SQL Server 2005 > Configuration Tools > SQL Server Configuration Manager. Expand out each of the options such as "SQL Native Client Configuration", "SQL Server 2005 Network Configuration" etc and ensure that TCP/IP is enabled under Client Protocols.
Nov 10, 2012 at 03:15 PM Tim

Awesome, this is great news. The reason for the Windows failure is you have not given access to the windows account. You can do this one of two ways, either grant it in the security section within SSMS, or you can add the windows domain account to the local administrators group which will make the user an SA. I recommend adding the user in SSMS in the security section and provision only the access that is needed.

I am very happy that our efforts have you working now. It took us 4 hours to get the resolution, but we got it done.
Nov 10, 2012 at 06:47 PM Tim

No problem Troy, luckily I was locked away in a room with nothing to do but listen to application folks trying to solve a problem. You helped keep me entertained. Where are you from? You should put your location on your profile. Also if you don't mind, check the box next to my answer of your question to mark it as the answer to show others that your question has been answered.

It was a pleasure interacting with you today, have a great rest of your weekend.
Nov 10, 2012 at 06:59 PM Tim
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x1945

asked: Nov 10, 2012 at 02:37 PM

Seen: 645 times

Last Updated: Nov 14, 2012 at 07:16 PM