x

Error on Login SQL Server 2012

I am getting the following error when I login to SS Management Studio 2012. I am kinda new to this and just installed ssMS and when IO try to login to the instance that was created at setup I get the followingf error: Any help would be appreciated

TITLE: Connect to Server

Cannot connect to PETEYBOY-PC.

------------------------------ ADDITIONAL INFORMATION:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=2&LinkId=20476

------------------------------ BUTTONS:

OK

more ▼

asked Oct 11, 2012 at 03:32 PM in Default

peteyboy gravatar image

peteyboy
0 1 1 1

(comments are locked)
10|1200 characters needed characters left

5 answers: sort voted first

If you forget to add your account as an administrator account during installation, and you are running on Vista and above or on Server 2008 and UAC is enabled, than no login was created for your account.

And until you elevate yor rights using UAC, then you are not even member of local administrators group.

In that case, launch the SSMS using UAC with elevated rights. Then try to login to your SQL Server Instance and create login for your account. Once the login is created, you can login without using the "Run As Administrator". Also if you want your account to be a sysadmin, don't forget to assign it sysadmin server role.
more ▼

answered Oct 11, 2012 at 06:24 PM

Pavel Pawlowski gravatar image

Pavel Pawlowski
22.3k 9 11 21

What is UAC? How do I get there?
Oct 11, 2012 at 07:11 PM peteyboy

UAC Is User Access Control and is enabled by default on Vista, Win7, Win8 and Server 2008+. It takes control over the security and ensures, that a program doesn't execute with administrative priviledges witout your attention.

If you want to run a program with elevated priviledges, then right-click on it and choose Run As Administrator
Oct 11, 2012 at 07:23 PM Pavel Pawlowski
Right click User Access Control? Where is it?
Oct 11, 2012 at 07:37 PM peteyboy
No, Right-Lick on the SQL Server Management Studio and select Run As Administrator
Oct 11, 2012 at 10:00 PM Pavel Pawlowski
same error
Oct 11, 2012 at 10:51 PM peteyboy
(comments are locked)
10|1200 characters needed characters left
Did you create a named instance and haven't specified it in SSMS?
more ▼

answered Oct 11, 2012 at 03:49 PM

Blackhawk-17 gravatar image

Blackhawk-17
11.9k 28 31 36

(comments are locked)
10|1200 characters needed characters left
I creTED ONE AND IT SHOWS UP IN THE LOGIN BOX i JUST HIT CONNECT ANDAFTER IT SPINS A WHILE i GET THE ERROR
more ▼

answered Oct 11, 2012 at 04:22 PM

peteyboy gravatar image

peteyboy
0 1 1 1

(comments are locked)
10|1200 characters needed characters left

Default instance or not?

Open SQL Configuration Manager then SQL Server Services. In the right pane, does it say SQL Server(MSSQLSERVER) or something else within the parentheses?  

If it is something else, connect to PETEYBOY-PC\somtehingelse or .\somtehingelse.

If that doesnt work. Go back to Configuration manager - SQL Server Network configuration - Click on your instance - right click tcp/ip (enabled?) - IP Addresses Tab - Scroll to the bottom and check TCP Port number

Try to connect to: .,yourportnumber or PETEYBOY-PC,yourportnumber
more ▼

answered Oct 12, 2012 at 11:36 AM

raadee gravatar image

raadee
2.8k 9 12 18

Not sure why the backslash got deleted!?
Oct 12, 2012 at 11:47 AM raadee
HTML editor... to have it show you need to delimit it with a backslash. So two in a row.
Oct 12, 2012 at 12:14 PM Blackhawk-17

\

Thanks!
Oct 12, 2012 at 12:15 PM raadee
(comments are locked)
10|1200 characters needed characters left
Nothing worked thanks guys what if I uninstall and reinstall itit
more ▼

answered Oct 12, 2012 at 12:43 PM

peteyboy gravatar image

peteyboy
0 1 1 1

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x165

asked: Oct 11, 2012 at 03:32 PM

Seen: 1776 times

Last Updated: Oct 12, 2012 at 12:43 PM