x

reporting service website not working

hello, I am having a problem with my reporting services. everything was configured correctly and installed before I started at this company. now when I try to access the report server or deploy reports to it i get this error: The report server installation is not initialized. (rsReportServerNotActivated)

HELP!!!! What did I break?!
more ▼

asked Jun 28, 2012 at 07:17 PM in Default

muk gravatar image

muk
400 30 33 35

@muk Probably nothing. The problem is probably caused by the fact that the reporting service is not running. Go to the box hosting SSRS, Start -> Run -> services.msc /s Check the status of the SQL Server Reporting Services. Amusingly, one of the reasons that it does not start one day is simply caused by the fact that the AD account used to run it has become disabled or simply changed its password.
Jun 28, 2012 at 07:27 PM Oleg
Oleg, thank you for your response. I did this and I do not even see SQL Server Reporting Services on the list. I checked this on my local machine. Do I need to do this on the server?
Jun 28, 2012 at 07:30 PM muk
@muk Yes, on the server which is hosting the database used by SSRS
Jun 28, 2012 at 07:50 PM Oleg
You should check server on which you should be running the reporting services. SSRS Database can be even hosted by another server.
Jun 28, 2012 at 08:13 PM Pavel Pawlowski
Is it able to access the database? Did you open up the reporting services configuration manager and ensure that connection can be made? Have you attempted to connect to reporting services from the server running the reporting services service to eliminate possible issues around local host files or DNS changes? Have you taken a look at the reporting services log files and checked for errors or issues there?
Jun 28, 2012 at 08:42 PM SirSQL
show all comments (comments are locked)
10|1200 characters needed characters left

1 answer: sort voted first

From the error code, it seems, that your report server is not properly configured and initialized.

Use the Reporting Services Configuration Manager to connect to that instance and verify, that the service is connected to correct SSRS database and that Report Manager and Report Service URLs are properly configured.

You can follow this MSDN article: [Initialize a Report Server][1]

[1]: http://msdn.microsoft.com/en-us/library/ms157133.aspx
more ▼

answered Jun 28, 2012 at 08:43 PM

Pavel Pawlowski gravatar image

Pavel Pawlowski
22.3k 9 11 21

I fixed it! I ran the process in this article http://social.msdn.microsoft.com/Forums/en/sqlreportingservices/thread/efcf30a1-7091-42ae-9a28-df017f950f2e

It was a problem with the encryption key. I had to delete all encryption keys through the configuration manager and then reconfigure the database settings.

Thanks Pavel!!!!!!
Jun 28, 2012 at 08:54 PM muk
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x1834
x581
x32
x23

asked: Jun 28, 2012 at 07:17 PM

Seen: 3253 times

Last Updated: Jun 28, 2012 at 09:53 PM