x

SSIS OLEDB task was successful but the records were not inserted into the table

Hi,

Can anyone explain why SSIS package executes for such a long time and fails with Login time out expired error ? When I try to load the same through BIDS, it executes fine but the OLEDB doesn't insert any records in any of the tables.

Thanks for your help.
more ▼

asked Jun 26, 2012 at 04:03 AM in Default

Ramya_B gravatar image

Ramya_B
0 1 1 1

Can you please give more details about your SSIS package?
Jun 26, 2012 at 07:42 AM Usman Butt
(comments are locked)
10|1200 characters needed characters left

1 answer: sort voted first

Couple of things to check:

  1. Connection Strings and permissions - verify that the service account you're using is actually pointing to the right place and has permissions.
  2. Check your source query - if you try to run multiple queries in one source, you could be ending early if you have a Rowcount returned. Setting ROWCOUNT OFF might help.
  3. Check your data flows and consider adding some data viewers to the mix. That could help you see where your data is dropping off.
  4. If you're getting to the very final insert with all of your data and it's still not inserting, you have another issue that is likely at the database server.
more ▼

answered Jul 12, 2012 at 02:27 PM

paschott gravatar image

paschott
20 1 1 1

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x937

asked: Jun 26, 2012 at 04:03 AM

Seen: 993 times

Last Updated: Jul 12, 2012 at 02:27 PM