x

executing package utility has stopped working

I created task for exporting excel data into SQL database and i have saved the task as SSIS package. Task got executed properly intially when i created.But when i run the SSIS package throught connceting integration services, i am getting following error "executing package utility has stopped working".I dont know why i am getting this error and i like to what is the cause for this error. i need to schedule the task which i have created.Is there any other option to do this?
more ▼

asked May 21 '11 at 08:19 AM in Default

liebesakt gravatar image

liebesakt
75 4 5 5

(comments are locked)
10|1200 characters needed characters left

2 answers: sort voted first
Is this on an x64 machine? I know there are issues using an Excel destination on x64 where you have to execute the package in 32 bit mode. I am not sure if it is a similar issue with imports. If this is with SQL 2005 try executing using something like (exec xp_cmdshell ”C:\Program Files (x86)\Microsoft SQL Server\90\DTS\Binn\dtexec.exe” /f C:\Blog\64bitExcel\64bitExcel.dtsx) as your sql job step. If you are using SQL 2008 or above you can add a job step for “SQL Server Integration Services Package” chose your package, click on “Execution options” and check the box for “Use 32 bit runtime”.
more ▼

answered May 21 '11 at 09:18 AM

Tim gravatar image

Tim
35.5k 32 41 138

I only add that it is related to the x64 version of SQL Server and x64 version of dtexec utility. It is not directly related to the x64 OS.

@TRAD, I would rather use an Operting System (CmdExec) Job Step type on SQL Server 2005 instead of executing the dtexec utility using the xp_cmdshell
May 21 '11 at 09:39 AM Pavel Pawlowski
(comments are locked)
10|1200 characters needed characters left
Got the solution. While running the SSIS package i didnt create a proxy account.Now i created a credentials and created proxy account and re-created the job again.Job ran successfully.
more ▼

answered May 22 '11 at 02:55 AM

liebesakt gravatar image

liebesakt
75 4 5 5

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x900

asked: May 21 '11 at 08:19 AM

Seen: 1592 times

Last Updated: May 21 '11 at 08:19 AM