x

xp_sendmail causing problem

I am using the SQL Server 2000.

On my server there are serveral job waiting to finish. I have found that xp_sendmail task in every package is not finishing and package is in wait condition on that step. Please can any body give help me why xp_sendmail is taking too long

any quick response is most appreciated.

more ▼

asked Dec 21, 2009 at 08:53 AM in Default

ijaz gravatar image

ijaz
13 2 2 3

(comments are locked)
10|1200 characters needed characters left

4 answers: sort oldest

There are several things to look at and a lot more information that would be helpful.

To start with, is sql server set with the correct information for your mail server? And similarly could there be any network problems or network slowdowns between SQL Server and the mail server?

What is the rest of the load on the server? Could it just be generally overwhelmed?

Are you certain that that it is the xp_sendmail call itself that is locking up and not something earlier in the procedure?

Does it give any error messages or warnings at all?

Does it eventually finish if you give it some exhorbitant amount of time, or does it seem to be perpetually locked there?

more ▼

answered Dec 21, 2009 at 02:11 PM

TimothyAWiseman gravatar image

TimothyAWiseman
15.5k 20 23 32

(comments are locked)
10|1200 characters needed characters left

Does an xp_sendmail command from SSMS complete quickly? What errors do you see?

As Timothy says, we need some mor einfo before we can be a lot more help...

more ▼

answered Dec 22, 2009 at 01:03 PM

Fatherjack gravatar image

Fatherjack ♦♦
42.4k 75 78 108

(comments are locked)
10|1200 characters needed characters left

I am getting the error in ERROR LOG, may be it will help you to understand the issue

SqlDumpExceptionHandler: Process 72 generated fatal exception c0000005 EXCEPTION_ACCESS_VIOLATION. SQL Server is terminating this process..

afterward, the execute xp_sendmail task is halted.

more ▼

answered Dec 22, 2009 at 01:20 PM

ijaz gravatar image

ijaz
13 2 2 3

Could you provide a code sample of the script you ran that generated this?
Dec 22, 2009 at 02:27 PM TimothyAWiseman
Does the server have all of the relevant service packs?
Dec 24, 2009 at 07:41 AM Fatherjack ♦♦
(comments are locked)
10|1200 characters needed characters left

What SP do you currently have installed? If it is not sp3, I would check out the kb article #329375:

http://support.microsoft.com/kb/329375

Also, Article #320407 may apply: Sorry, as a new user, I can only post one link.

more ▼

answered Jan 20, 2010 at 02:46 PM

user-974 gravatar image

user-974
46 1

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x985
x473
x15

asked: Dec 21, 2009 at 08:53 AM

Seen: 1744 times

Last Updated: Dec 21, 2009 at 10:29 AM