x

SSRS 2005 change default port

Hi, I'm trying to get SSRS 2005 running on the remote (client's) server. It's been installed a long ago and never run. The Reporting Service Configuration tool shows all the "green"; the reporting databases are created; the default web directories are showing up under IIS; the configuration files are created... nothing works :) - I cannot connect to SSRS from the Management Studio ("The request failed with HTTP status 404: Not Found"); cannot get to Report Manager ("[server name] is not set up to establish a connection on port World Wide Web service (HTTP) with this computer"; cannot deploy reports to the report server - throws the "Reporting Services Login" screen... The only hint that the client was able to give to me that the port 80 is used by another application. Maybe I could try to configure Reporting Services to use a different port? But I cannot find how to change it in SSRS 2005. I'd appreciate sharing of any experience with a similar situation! Thankyou, - Tatyana
more ▼

asked Apr 14 '11 at 09:16 AM in Default

Tatyana gravatar image

Tatyana
413 15 15 18

(comments are locked)
10|1200 characters needed characters left

1 answer: sort voted first

SSRS 2005 utilizes IIS. You need to change your installation setting for IIS for this. You didn't mention which OS you are running so here are your options for IIS 6 (Windows 2003) and IIS 7 (Windows 2008).

For IIS 6.0 (windows 2003), in Start menu/Control Panel/Administrative Tools/Internet Information Service (IIS) Manager, expand YourComputerName(local computer)/Web Sites, right click Default Web Site, select Properties, in pop-up window, change TCP port as your want, and then click Apply.

For IIS 7.0 (windows VISTA/7/Server 2008/R2), in Start menu/Control Panel/Administrative Tools/Internet Information Service (IIS) Manager, expand YourComputerName(domain/username)/Sites, right click Default Web Site, select Edit Bindings, in pop-up window, select the binding you want to change, and click edit, change its port as you want, click OK and then close the window.
more ▼

answered Apr 14 '11 at 10:10 AM

Tim gravatar image

Tim
35.5k 32 40 138

TRAD, thank you, that did it! I've changed the port. This did not help Reporting Service (as I hoped), so I'll accept you answer and will repost my question with a different problem description. Thank you, again, that was great! Tatyana
Apr 14 '11 at 10:59 AM Tatyana
Thanks, at least you are one step closer. When you post your next question please include as much detail about your environment. OS level of your DB server and client you are running Management Studio etc. Any errors, etc. I have some experience with SSRS, mostly trial and error like your self but I have installed in on numerous environments from Server 2003 with SSRS 2005, Windows 2008 with SSRS 2005 and 2008, etc.
Apr 14 '11 at 11:04 AM Tim
TRAD, it turned out that your advice finally helped me to resolve the whole problem!! Under the same "Edit Binding" option there was also "IP Address" setting, and it was set to some address that, it seems, did not exist any more. I changed it to "All unassigned", and the life was finally back to that SSRS. Thank you so much!
Apr 18 '11 at 01:42 PM Tatyana
@Tatyana, thank you for the followup. I am very happy that I was able to help guide you to a resolution. I hope to continue seeing you on here asking questions and helping to answer others as well.
Apr 18 '11 at 07:18 PM Tim
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x1933
x535
x7

asked: Apr 14 '11 at 09:16 AM

Seen: 1901 times

Last Updated: May 19 '11 at 12:50 AM