x

Low Physical Memory - Red Gate

Hi, I am now getting the following message from Red-Gate Response.

Low physical memory: Server_01
Server : Server_01
Alert Level : Medium
Occurred at : 26/10/2010 09:41:53
Description : Low physical memory on Server_01

It has 24GB on the server. 2147483647 Maximum Server Memory in (MB). I don't think server need more memory.

Why I keep getting that message? Memory Leak somewhere???

more ▼

asked Oct 26, 2010 at 08:56 AM in Default

Leo gravatar image

Leo
1.6k 54 56 58

@Leo - you can change the thresholds for alerts on sql response. Your problem here is that Max Memory is not set, but the threshold may also be changed to a lower value if you wish
Oct 26, 2010 at 12:02 PM WilliamD
+1 WilliamD's comment - the Red Gate tool works out of the box with a default set of thresholds that may or may not apply to your setup. If you had SQL sharing a server with another function (shudder), then memory config would be lower than if the box is a dedicated db server.
Oct 26, 2010 at 12:14 PM Kev Riley ♦♦
Hi Will - Where about in SQL Response to change the threshold? I have version 1.3.
Oct 27, 2010 at 01:52 AM Leo
@Leo - I can't quite remember, we don't use it here. It was somewhere around the server and alerts themselves. Read the help file or get in touch with Red-Gate, they will help you out.
Oct 27, 2010 at 01:57 AM WilliamD

Will - I will have a look in Help file or I might phone them if I can't find it.

Kev - that is pure SQL Server, not sharing with anything.

So..is that worth to set Max Memory??
Oct 27, 2010 at 02:01 AM Leo
(comments are locked)
10|1200 characters needed characters left

1 answer: sort oldest

Limit the max server memory on SQL Server so that it doesnt starve the OS for memory and see what happnes. If SQL is the only one running on that machine you can limit SQL around 20GB and leave the rest for the OS.

Try something in the line of:

EXEC sys.sp_configure N'show advanced options', N'1'  
RECONFIGURE WITH OVERRIDE
GO
EXEC sys.sp_configure N'max server memory (MB)', N'20000'
GO
RECONFIGURE WITH OVERRIDE
GO
EXEC sys.sp_configure N'show advanced options', N'0'  
RECONFIGURE WITH OVERRIDE
GO
more ▼

answered Oct 26, 2010 at 09:06 AM

DaniSQL gravatar image

DaniSQL
4.9k 33 35 39

yes i agree with DaniSQL ,but first check the buffer cache hit ratio it must be 100%, check page life expectancy ,if it is less than 300, then it as a memory leak, check your stored procedure,or other application running in the server,slow running queries, if your sql server is 64 bit, then ignore it, it is the good advantage of sql server 64 bit,
Oct 26, 2010 at 09:17 AM ramesh 1

@DaniSQL +1: Setting Max Memory should solve the problem here.

@Ramesh, page life expectancy and buffer cache hit ratio are not fixed values to try to attain. They should be as high as possible, but do not mean you have a memory leak when they are at less than 100% and less than 300 seconds respectively.
Oct 26, 2010 at 11:29 AM WilliamD
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x1839
x13

asked: Oct 26, 2010 at 08:56 AM

Seen: 1455 times

Last Updated: Oct 26, 2010 at 08:56 AM