x

Tables not shown when creating an ODBC connection

I have two SQL servers, one 2000 server, and a 2005 server.

As far as I can tell the permissions are configured the same, when I add an ODBC connection to the 2000 server, in the "Administrative Tools, Data Sources (ODBC)" where is says "Change default database to" I can click the down arrow and see a list of all tables on this server. But when I create a connection to the 2005 server I cannot see all tables, only master and tempdb.

Why can I not see all tables on the 2005 server?
more ▼

asked Sep 20, 2010 at 11:01 AM in Default

Larry gravatar image

Larry
21 2 2 2

Can you please review your question and correct anywhere that you have typed 'tables' but actually meant 'databases'please? master and tempdb are databases, not tables.
Sep 20, 2010 at 11:32 AM Fatherjack ♦♦
(comments are locked)
10|1200 characters needed characters left

1 answer: sort voted first
I would hazard a guess that the issue is security. It sounds like the login being used to access the Server doesn't have access to any of the databases. You should try connecting with a different account, one that you know has the access, or have someone else do that for you, and check the security setting for the login attempting to connect.
more ▼

answered Sep 20, 2010 at 11:56 AM

Grant Fritchey gravatar image

Grant Fritchey ♦♦
97.9k 19 21 74

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x1943
x473
x85
x37

asked: Sep 20, 2010 at 11:01 AM

Seen: 1215 times

Last Updated: Nov 22, 2010 at 03:58 AM