x

ssis package job failing

Hi I have an ssis package which runs fine when a developer runs from visual studio. But when we create a job for it its failing. What might be the cause. I dont have the exact error message..

The job was created by a developer with his credentials and as he left the comapny and his credentials expired then job started failing. From then we are running from visual studio.

are there any workarounds...
more ▼

asked Sep 15, 2010 at 02:16 PM in Default

munna gravatar image

munna
51 5 5 6

(comments are locked)
10|1200 characters needed characters left

4 answers: sort newest

1st thing, please check dtexec is enabled or not

2nd thing, some pakages will run based on the system variables (like 32 bit or 64 bit environmrnt). If the package is is configured to run under 64 bit environment and operating sytem is 32 bit environemtn then you need to disable 62 environment on ssis configurations.
more ▼

answered Dec 31, 2010 at 06:58 AM

CVA gravatar image

CVA
11

(comments are locked)
10|1200 characters needed characters left
Re-import the job and chose to use the server for the sensitive data, its the last option in the list. That should do the trick.
more ▼

answered Sep 15, 2010 at 07:37 PM

Tim gravatar image

Tim
36.4k 35 41 139

(comments are locked)
10|1200 characters needed characters left

Are the connections all windows based? If they are then create Credentials and a proxy account, and then run the SSIS package as the proxy account. See this link for info on how to create credentials and run as a proxy account http://www.sqlservercentral.com/articles/Integration+Services+(SSIS)/69441/

more ▼

answered Sep 15, 2010 at 04:57 PM

Daniel Ross gravatar image

Daniel Ross
2.9k 10 12 14

(comments are locked)
10|1200 characters needed characters left

You can try to navigate to this job from SSMS and change the owner of the job (under general tab). In the worst case scenario when for whatever reason SSMS will not let you to even view it, you can re-enable AD account in question, change its password, login to SSMS with his new credentials, change the owner, and then disable AD account again.

Oleg
more ▼

answered Sep 15, 2010 at 02:23 PM

Oleg gravatar image

Oleg
15.9k 2 4 24

we tried changing the owner of the job... I think there is something like save sensitive data with password for ssis packages..
Sep 15, 2010 at 02:36 PM munna
In that case, open the dtsx file on the server. From the file menu choose Save Copy of Package. This will enable you to change the security settings. Change the package protection level to: Do not save sensitive data.
Sep 15, 2010 at 08:02 PM Scot Hauder
(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x927
x86

asked: Sep 15, 2010 at 02:16 PM

Seen: 1555 times

Last Updated: Sep 15, 2010 at 02:16 PM