x

Error printing from Report Viewer

Hello,

We have a report server configured in Sharepoint integrated mode (SQL Server 2008). I designed a report that can be viewed using Microsoft Report Viewer 2008 (SP1). Works fine. The problem appears when we try to print and Preview the report.

  1. For some reason once I click on 'Preview' button I am asked to enter credentials. My LAN ID does not work but some other account seems to be ok. This is weird as my understanding is that it does not ask for an authentication on the domain but for some server (SQL Server box) authentication??

  2. Once I enter the credentials using a service account and I print, I get the following error: An error occurred during printing (0x8007F303) but the report is printed anyways. I did a lot of search about this error but nothing worked so far.

Additional information: Windows Server 2003 SP2 (64 bit), Sharepoint 2007 SP2 (64 bit), SQL Server 2008 SP1 (64 bit), Report Viewer 2008 SP1, .NET Framework 3.5 SP1

Any help will be greatly appreciated, M. Rusu

more ▼

asked Oct 20, 2009 at 05:03 PM in Default

Mircea gravatar image

Mircea
49 2 2 3

(comments are locked)
10|1200 characters needed characters left

3 answers: sort voted first

Thanks everyone for taking the time to answer my question.

I didn't try these solutions yet as we found the following: It is a client browser setting: Internet Options -> Privacy -> set it to 'Low" and the issue goes away!

more ▼

answered Nov 12, 2009 at 01:33 PM

Mircea gravatar image

Mircea
49 2 2 3

(comments are locked)
10|1200 characters needed characters left

It happened to me once but with SSRS2005 and all I needed to do was add the accounts which had that problem to the report manager in the security option of the folder that contained my reports, and that was it.

more ▼

answered Oct 28, 2009 at 12:50 PM

Michael Villegas gravatar image

Michael Villegas
11 1 1 1

(comments are locked)
10|1200 characters needed characters left

You may need to try and reinstall .net 3.0 sp1 (or latest SP).

Had a similar issue and the post below pointed me in the right direction.

http://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=307315

more ▼

answered Oct 21, 2009 at 06:12 PM

sp_lock gravatar image

sp_lock
9.3k 25 28 31

(comments are locked)
10|1200 characters needed characters left
Your answer
toggle preview:

Up to 2 attachments (including images) can be used with a maximum of 524.3 kB each and 1.0 MB total.

New code box

There's a new way to format code on the site - the red speech bubble logo will automatically format T-SQL for you. The original code box is still there for XML, etc. More details here.

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

SQL Server Central

Need long-form SQL discussion? SQLserverCentral.com is the place.

Topics:

x1846
x558
x11

asked: Oct 20, 2009 at 05:03 PM

Seen: 4346 times

Last Updated: Feb 09, 2010 at 08:09 AM